Symptoms
When clicking on 'view in model', the viewpoint seems to be well positioned but doesn't correspond to the thumbnail image. Despite changing the 'view in model' options from the Newforma Konekt settings, other elements appear that shouldn't be there.
Causes
The 'view state' of the viewpoint isn't remembered by Newforma Konekt, and this can be caused by several factors including the original model's configuration.
Resolution
Ideally, the coordination file format should be an NWF/NWC. You can create issues on any other supported file type such as a DWG, although the latter isn't made up of actual elements but rather is based on model geometry. This means that some functions such as the 'isolate elements' won't work on a DWG.
If you're working within Navisworks and your models come from Revit, you should follow these steps:
-
- Convert element Ids
- Convert ALL element parameters
- Convert element properties
-
Shared Coordinates
Make sure that the ‘Save view state’ boxes are enabled in the Newforma Konekt settings. (If they weren't, this likely explains why you couldn't isolate the elements or load the expected viewpoint when clicking on 'view in model'. You'll have to recreate or update those viewpoints in order to implement this modification)
Note that if your Revit file includes linked models as well, the ‘ Collapse on Convert ‘ option should be set to 'All Objects'.
- Upon exporting your RVT model as an NWC file, verify if these four options were checked in the 'Navisworks Settings'. If not, you can reexport your model to Navisworks as a copy in order to run a test.
- The same configuration should be mirrored in the Options Editor within Navisworks itself.
- Once these options are all checked, perform a test by adding a viewpoint to an existing issue from the NWF/NWC that you just created. You can then click on 'view in model' for that viewpoint. It should yield the expected result.
If the 'view state' still isn't preserved despite having the recommend options all checked, or if your initial setup differs from what is described in these steps, feel free to reach out to support@bimtrack.co