Symptoms
When relying on Newforma Konekt's publish tool in Revit, the upload might get stuck in Revit. The upload can also stall in our Viewer whether the IFC comes from our publish tool or was manually added.
The upload might remain at a certain percentage without progressing. Sometimes, a red 'x' will appear in our Viewer's Project Tree.
Causes
It is likely that a class of elements is preventing the upload from completing. Although it is rare, it can happen since no browser supports IFCs directly. For this reason, Newforma Konekt has to first convert the IFC into a supported format.
Resolution
If the issue occurs while using our publish tool in Revit, try to export the IFC using Revit's IFC exporter instead. If the process still stalls or fails without Newforma Konekt being involved, this means that the issue lies with Autodesk and not Newforma Konekt. You should then contact their support: https://knowledge.autodesk.com/contact-support
If the stall or failure occurs while the IFC is uploading to our Viewer, you should follow these steps:
- Make sure that classes of elements such as grids, annotations and any unnecessary classes are excluded from the IFC export. In Revit, this can be done from the IFC Options by switching the value to 'Not Exported'. You can then upload your IFC to the Viewer to see if these changes make a difference.
- If you're relying on our publish tool, you should reduce the level of detail of your model from the Modify Setup window. Some models might contain a vast quantity of small elements causing the upload to stall and this setting will help.
After following these steps, you should at least once leave the upload active for an hour especially if you're working with larger models. The elements can take some time to process and what looks like a stall isn't always so (unless the red 'x' appears in the Project Tree).
If you're still experiencing this issue despite having followed these steps, please reach out to us.